
MPC Release Notes !
About 

Akai Professional is continually updating and enhancing the MPC experience. 

This document lists the new features, fixes and improvements made to your MPC 
software. 

Version 1.7.1  (October 2014) !
New features 

◾ Pad Keys (See Tools>Pad Keys). Drive the pads and banks from your computer 
keyboard. Use 1/2/3/4, Q/W/E/R, A/S/D/F and Z/X/C/V to emulate pad presses. Use 
[ and ] to switch pad banks. Use J/K/L to set pad input velocity (to quarter level, half 
level, full level). 

◾ New keyboard shortcut (and menu item) to change sequence immediately, and to 
change after current sequence finishes playing (See Edit>Sequence>Next 
Sequence Now). 

◾ Mixer view filters are remembered between runs of MPC. Your favorite mixer setup 
is now permanent! 

◾ Menu item for launching the MPC expansion pack store. 
  !



◾ Solo operations are now automatable. !
Improvements 

◾ Insert effects in the “assignable parameter” LCD pop-up (accessed from main 
mode) launch the insert editor when you press Window. 

◾ Audio export defaults to saving in the project’s directory. 
◾ Improved performance of Expansion Browser when viewing many expansion 

packs. 
◾ Improved program change and bank change (LSB/MSB) MIDI message support. 
◾ Improved stability of file load/save operations. 
◾ Improved VST plugin scanning performance. 
◾ Improved audio path performance. 
◾ Bug fixes and stability enhancements. !

Version 1.7  (September 2014) !
Important note 
This is a major MPC release with many new features and important enhancements. 
Please be aware that the audio architecture has changed significantly. All old MPC 
projects will load into version 1.7 and should still sound identical. However, the old 
project structure will be converted into the new MPC 1.7 format. The files you save 
will not be backwards compatible with MPC version 1.6 or earlier. 

New hardware support 

◾ Support for MPC Studio Gold. !
New mixer architecture 

◾ Tracks are no longer audio channels, but house MIDI data. 
◾ Each program is an audio channel, complete with its own insert effect chain and 

audio routing options. All program automation (e.g. pad/program audio channel 
mixer settings, plus other pad/program automatable parameters) is recorded per-
program in each sequence. 
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◾ All mixer channels now have headroom, and can apply up to 6.0 dB boost. (This is 
available on pad audio strips, program audio strips, the metronome and master 
volume controls). 

◾ All mixer values are shown accurately with dB values. This appears on slider scales 
and on all value tooltips. 

◾ Audio VU meters reflect accurate audio values in dB. 
◾ Audio VU meters have peak hold. 

◾ Click to reset the peak value. 
◾ Clipping audio channels are indicated by a red peak value. 

◾ The Program Mixer shows a program audio channel strip to the right of the mixer.  
◾ This allows you to control the overall program level and add inserts in the 

context of entire-program mixing. 
◾ You can hide this by deselecting “Show program strip” in the mixer sidebar. 

◾ Program Mixer improvements when mixing pads: 
◾ Pads route audio to their associated program audio channel by default. 
◾ Enabling pad inserts no longer routes to a submix — the pad continues to 

route to it’s program audio channel. 
◾ Program Mixer now shows VU meters for every pad. 
◾ A pad indicator below the channel strip indicates pad activity, and allows 

you to preview a pad sound in the mixer. You can drag a sample onto this 
pad from the file browser. 

◾ New Program Mixer strip filters available in the Program Mixer sidebar: 
◾   Show all pads (to show all pads, including unused pads) 
◾   Show pads with samples 
◾   Show pads with events 
◾   Show pads with samples or events 
◾   The “events” filters can check for events on the current track only, or on all 

tracks in the current sequence. 
◾ New Track Mixer strip filters available in the Track Mixer mixer sidebar: 

◾   Show tracks (de-select this to hide all MIDI track strips). 
◾   Show all tracks (to show all tracks, including all unused tracks). 
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◾   Show programs (de-select this to hide all program audio channel strips). 
◾   Show unused programs (de-select this to hide programs that are not used 

in the current sequence). 
◾ New keygroup mixer (shown in Program Mixer Mode for a keygroup program) 

allows you to add inserts to individual key groups and mix keygroups directly. 
◾ Program Edit Mode allows you to adjust pad and program inserts. 
◾ Drag-and-drop insert effects between pad strips, program strips, and the master 

insert effect slots. 
◾ Drag an insert to move it into a new slot. 
◾ Hold control/command to copy the effect to the new insert slot. 

◾ Alt/Option click on all faders, knobs and sliders to reset to the default value. This 
works in all mixers, for the metronome volume, master volume, and sample 
audition volume controls. 

◾ GUI mixer channel strips show the current track/program/pad with a red highlight 
ring. 

◾ Click a mixer channel strip to select it as the current track/pad. !
New automation architecture 

◾ Individual programs now have automation “arm” mode: Off, Read, Write. 
◾ Press the       icons on the channel strip to toggle Off, Read, and Write arm 

modes. When there is recorded automation you must hold Shift to enter Off mode 
(without Shift-clicking the button will toggle Read and Write arm modes only). 

◾ If a program is armed in Write mode, all automation adjustments (to its mixer 
settings, Program Edit Mode setup, pad settings, and program/pad insert effects) 
will be recorded into the program. Automation is written whether the transport is 
in Record mode or in Play mode. 

◾ The GUI toolbar provides a “global” automation control. Selecting a global state will 
force all programs into this automation arm mode.       

◾ The Q-Link Trigger hardware button acts as an automation arm control. The 
button illuminates in Read arm mode, and flashes in Write arm mode. No light 
shows when automation is Off. 
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◾ When there is automation recorded you have to simultaneously press the 
Shift hardware button to enter the Off arm mode. 

◾ In the LCD preferences you can set the Q-Link Trigger button behavior 
page to be: 

◾ Control current program automation arm state. 
◾ Control global program automation arm state. 

◾ Many more MPC parameters are now automatable. 
◾ You can automate many more drum program parameters. 
◾ You can record automation for program insert effects. 
◾ You can record automation for pad insert effects. 

◾ Selection of automation parameters has been vastly improved, with a hierarchical 
menu providing access to track (i.e. MIDI CCs), program (drum program or software 
plugin instrument) parameters, pad insert parameters (for drum and keygroup 
programs), and insert effects. 

◾ MPC GUI editors denote automation event types clearly with color-coded icons. 
◾ Orange icons are performance events, green icons are track (MIDI) events, 

blue icons are program automation events, red icons are pad automation 
events. 

◾   note events,   performance data (aftertouch, pitch bend, channel/note 
pressure events),   track “mixer” MIDI event,   other track MIDI event,   
program mixer automation,   program parameter automation,   program 
insert effect automation,   pad mixer automation,   pad parameter 
automation,   pad insert effect automation. !

Other new features 

◾ AAX plugin format for Pro Tools 10 and 11. 
◾ Multi-processing audio path to improve audio performance. (You can configure 

this in the “Other” Preferences window tab). 
◾ AIR’s Hybrid 3 virtual instrument integrated deeply into MPC. 

◾ Hybrid appears in the plugin program instrument browser under “MPC 
Expansions” and in the new Expansion Browser sidebar. 
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◾ A custom Hybrid Program Edit Mode layout allows hands-on live control of 
common Hybrid 3 controls on the Q-Links. 

◾ An integrated Program Edit Mode GUI layout shows these Hybrid controls 
clearly. You can open the standard Hybrid GUI in a separate window for fine 
control of all Hybrid settings. 

◾ MPC’s Hybrid 3 is compatible with standard Hybrid 3 presets, so any presets 
you install will instantly appear in MPC. 

◾ You can access the Hybrid 3 manual from the Help menu. 
◾ Integrated Expansion Browser providing a more streamlined way to access your 

MPC instrument and sample expansion packs. Press the expansion button in the 
bottom-left of the GUI file browser to switch to/from expansion browser mode. 

◾ Sample expansion pack contents are accessible by program, sample, 
sequence or demo project. 

◾ Virtual instrument expansions are accessible by their preset. 
◾ Loading an expansion demo sequence will automatically load the 

corresponding program. (Hold shift when loading to skip this.) 
◾ Hold shift when loading a program to auto-load the corresponding demo 

sequence. 
◾ Direct Record in Sample Record Mode. When you record audio with the transport 

running, you have the option to “Add Event” when you assign the new sample to a 
pad. Selecting “Add Event: Yes” here will insert an event on the timeline at the exact 
time you made this recording, so the new sample plays seamlessly in your project 
You can use this to create complex layered recordings very easily. 

◾ The file browser sample audition has a configurable audition volume. Select this in 
the GUI via slider or using the “Volume” F-Key button on the LCD Browser window. 

◾ Q-Link controls are enhanced to be able to control many more parameters. 
◾ Improved Q-Link pad mapping menu. 
◾ Access to many more drum program parameters. 
◾ Better selection of insert effects and insert parameters. 

◾ New plugin scanner: 
◾ Crash protection for scanning unreliable/buggy plugins. 
◾ Scans plugins concurrently for faster results. 
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◾ Improved scanner output, showing progress and results more clearly. 
◾ Ability to drag a VST into the project info area to scan it quickly. 

◾ Enhanced audio export: 
◾ Ability to automatically “explode” the audio export: 

◾ by program, and 
◾ by track. 

◾ Optional mixdown of the master insert effects when exporting master 
outputs. 

◾ Optional mixdown of the insert return buses as separate files when 
exporting tracks and programs. 

◾ Track Explode function (See Edit>Track>Explode). 
◾ Drag pads Main Mode to move/copy them. 

◾ Drag from one pad onto another pad to move it. 
◾ Hold control/command to copy the pad into the new pad. 

◾ A GUI keyboard display can be shown at the bottom of the screen. (See 
Tools>Show MIDI Keyboard). This shows the notes being played on the current 
track, and allows you to enter notes directly into MPC. 

◾ MIDI Keys: You can use your computer keyboard to input MIDI notes (See 
Tools>MIDI Keys). The QWERTY keys A to ; and W to P act as a piano keyboard. You 
can adjust the octave played using the [ and ] keys. 

◾ Duplicate to new track: Duplicate a program to new track: Right-click a program 
in the project info list and select “Duplicate to new track”. This makes a new copy of 
the program, assigns it to the next unused track, and switches to that track. 

◾ MPC toolbar shows a MIDI input indicator as well as a MIDI output indicator. 
◾ Support for Akai MPK keyboards. 
◾ Registration information shown in a Preferences window tab. 
◾ New View menu, allowing you to select MPC mode, and toggle various editor view 

settings. 
◾ Keyboard shortcut controls for many common operations: 

◾ M: Note erase 
◾ N: Note repeat 
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◾ Control/Command + 1 through 0: Change MPC mode 
◾ Shift + Control/Command + W: Show/hide GUI keyboard 
◾ Control/Command + W: Toggle MIDI keys 
◾ Shift+Control/Command + K: Show TC settings 
◾ Control/Command + [ or ]: Track down/up 
◾ Shift+Control/Command + [ or ]: Sequence down/up 

  
Workflow improvements 

◾ Sequence playback position and loop start/end points shown as a progress bar 
overview in Main Mode and Sample Record Mode. 

◾ The Main Mode GUI panel now shows a program audio channel strip beside the 
pads, for quick access to inserts and mixer setup. (For MIDI programs, this shows 
the current track MIDI strip.) 

◾ One shot audition option in Sample Edit Mode. In Trim Mode pads 1 to 4 audition 
the sample as One Shot, pads 5 to 8 as Note On. In Chop Mode you can select 
whether to audition as One Shot or Note On. 

◾ Press and hold the Shift button to see the name of the items being mixed on the 
LCD (i.e. the program, track, or pad name). 

◾ Main Mode screen has an Assignable Parameter display. Place the cursor over the 
“Vel%” field and press the Window button to show and edit more track/program 
values. Highlight a field and press “Set” to show this parameter on the main screen. 

◾ Faster hardware pad copy workflow: Press and hold Shift. With Shift held: Press 
Pad Copy, tap the “from” pad and then tap the “to” pad. The pad is instantly copied. 
Continue to hold Shift and press Pad Copy again to quickly make more pad 
copies. 

◾ LCD mixers show accurate dB values. You can set the whole and fractional part of 
these for fine control, or use The MPC Renaissance numeric keypad to type in a 
new dB values. 

◾ Hold down Shift when adjusting a Q-Link for fine-grained control of a parameter. 
◾ Double-tap the Note Repeat button to latch note repeat mode. 
◾ Multiple pad selection is shown on the pad lights in Program Edit Mode. 
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◾ Enhanced Program Edit Mode pad selection. Highlight an editor field and 
press the Window button to refine the pad selection. 

◾ Sample Record Mode shows the “Now” position, a sequence progress overview bar, 
and the current sample recording length. 

◾ Holding Shift whilst pressing +/- in LCD lists jumps by ten items. 
◾ Program Edit mode keygroup selection improved: press Shift+pad to select the 

keygroup that this pad will trigger. Continued Shift+pad presses cycle through all 
keygroups that apply. 

◾ MPC grid editors automatically switch to show newly recorded automation events. 
◾ GUI list editor improved, with clearer display and enhanced event editing. 
◾ Program lists and menus are no longer separated by program type, all programs in 

your project are selectable from the same list. 
◾ Single-click in the sample editor Chop Mode waveform to insert a new slice point. 
◾ Audio recording improvements in Sample Record Mode: 

◾ Audio recording does not truncate the start of the sample. 
◾ LCD shows accurate recording length during the recording. 

◾ Master volume/metronome volume knob tooltips show the currently selected level 
for better volume control. 

◾ Enhanced file browser: 
◾ Performance enhancements: sample preview is more responsive. 
◾ GUI: Click a sample again to re-preview. 
◾ GUI: Folder drop-down menu lists all installed expansion packs for easy 

access. 
◾ File Browser automatic sample audition play duration is configurable (See 

Preferences>Other>Audition Auto Play). 
◾ Grid editor piano roll shows the currently playing notes (for MIDI programs and 

plugin programs). 
◾ Improved automation and MIDI control change menus, and the on-screen display 

of these selections. 
◾ Sixteen Levels setting is saved and restored between MPC uses. 
◾ Loading a sequence file into an unused sequence does not prompt for which 

sequence to load into. 
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◾ Unused pads behave more consistently in the mixers. 
◾ New plugin dialog remembers filter settings. 
◾ Many other minor LCD and GUI workflow improvements. 
  
Improvements 

◾ Increased the number of virtual outputs available when running MPC as a plugin. 
◾ MPC handles a missing audio device more gracefully. 
◾ Improved and more reliable virtual instrument hosting. 
◾ Audio path optimizations. 
◾ Many bugfixes and stability enhancements. 
◾ !!

Version 1.6  (November 2013) 
  

New features 

◾ List Editor: Provides a GUI and LCD-based event editing interface for fine-tuning 
event lists. Click the GUI list toolbar icon to switch between grid or list view. SHIFT-
press STEP SEQ to enter the LCD list editor. 

◾ Note length quantize: adjusts the position of the note ends, or make notes play 
legato. 

◾ New editor scrolling behaviour: toolbar buttons toggles between scroll modes: Off, 
Page, Scroll. 

◾ Added MIDI control mode layouts for pad chromatic scale layout. !
Improvements 

◾ Bugfixes and stability enhancements. !
Version 1.5  (September 2013) 

  

New features 

◾ MIDI control mode: use your MPC hardware as a configurable MIDI control surface. 
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◾ MPC software runs without hardware present; use MPC on the road without 
plugging in hardware. 

◾ Configurable pulse display resolution (set this in Preferences>Sequencer). !
Improvements 

◾ 16-levels now works instantly. 16-level engages as soon as you hit the button. Press 
and hold 16 LEVEL, then tap a pad to change pad assignment on the fly. 

◾ Improved project information display, including a tree-view of project contents, 
improved icons displaying program and sample types, and built-in sample 
auditioning. The sample list is context sensitive, and shows only the samples used 
by the current selection (i.e. the selected sequence/track/program). 

◾ Many UI and workflow improvements.  
◾ Purge samples workflow improvement. 
◾ Next sequence mode and song mode show sequence loop points in the timeline. 
◾ Improved timeline editing. You can now extend a sequence and set loop points 

directly in the timeline. 
◾ Improved stability hosting various third party plugins. 
◾ Improved drag and drop capabilities. 
◾ Plugin editor window position made persistent. 
◾ Improved behavior when an audio interface is removed. 
◾ MPC saves the master level and submix levels in project files. 
◾ Support for MPC Element hardware. 
◾ Compatibility with MPC Essentials projects. 
◾ Performance enhancements. 
◾ Many bugfixes and stability enhancements. !

Version 1.4  (April 2013) 
  

New features 

◾ 64-bit support for PC/Mac. The standalone application, VST and Audio Unit plugins 
now have 64-bit versions. 
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◾ Ability to load samples when playing. 
◾ Ability to export return buses. 
◾ Auto-save function (see preferences window). 
◾ New AD envelope type (see Program Edit mode). 
◾ Control surface buttons auto-repeat when you hold them down (useful for zoom, 

locate, etc). 
◾ Quick bank/mode selection via button double-tap. You can double-tap shift to 

enter “shift lock” mode. You can also double-tap bank/mode buttons directly. 
◾ Multiple file selection in file browser. 
◾ New file browser folder button behavior. The 1-5 buttons retain their stored 

location when you move away from them; the location can be set by holding shift 
as you press. 

◾ QLink control of zoom and scroll in the sample editor. 
◾ Added a sample overview in sample editor. 
◾ LCD sample editor supports zoom and scroll. 
◾ MIDI clock receive. 
◾ Ability to alphabetically sort the samples list (see button over the Sample list) 
◾ New command history window, with the ability to drag the undo position around 

(Edit>History…). 
◾ Holding shift at startup skips any autoload files. !
Improvements 

◾ Improved performance when switching sequences suddenly. No more dropped 
beats! 

◾ Improved display of events in the track view. 
◾ Grids and lists show when they have lost focus. 
◾ Title bar shows "+" when the project has unsaved changes. 
◾ Updated the UI in many other areas. 
◾ Click and drag in grid headers to audition a range of events. 
◾ Track view supports region select across multiple tracks. 
◾ Undo/redo buttons on toolbar. 
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◾ Effects selection has updated UI, with sort by vendor/type. 
◾ Address issue where some plugins and MIDI equipment react badly to MIDI volume 

changes. (Volume control messages are not sent on a track unless explicitly set. 
Until set, the fader shows a “?”.) 

◾ Rationalize track types. 
◾ You can now assign "no program" to a track. 
◾ Automation chase when relocating playback position. 
◾ Optimization and performance improvements for better workflow. 
◾ Fixed many bugs. 
◾ Fix MIDI sync send. 
◾ Fixed hardware screen corruption issues. 
◾ Fixed software unlock issue experienced by some users. 

  
Version 1.3.1  (March 2013) 

  

This release addresses some minor issues in version 1.3: 

◾ Newly loaded projects play at the correct tempo. 
◾ Fixed issues with MPC 5000 import. 
◾ Fixed issues with sample audition from file browser. 
  

Version 1.3  (February 2013) 
  

New features 

◾ Completely redesigned plugin architecture, allowing more features and flexibility. 
You can route multiple tracks to the same plugin. 

◾ ProTools transport control (see Help menu for setup instructions). 
◾ New vintage emulation mode: SP1200 Ring. 
◾ Hardware zoom control (press shift + cursor keys). 
◾ Project archive facility, to easily move projects between computers (File>Export>As 

Project Archive). 
◾ Facility to delete all unused samples in a project (Edit>Delete Unused Samples). 
◾ File import of MPC2000 and 2000XL format APS and ALL files. 
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◾ Support for custom program edit UIs for plugin programs. The bundled 
instruments now have tailor-made editors. !

Improvements 

◾ New program mixer, with ability to hide unused tracks, and show mixer strips for 
plugin programs. 

◾ Improved plugin selection system, allowing you to browse by plugin type, and by 
manufacturer. 

◾ Redesigned main mode GUI, making information clearer and speeding up the 
workflow. 

◾ Added new track and sequence selectors to speed up access. 
◾ Project info list shows program type and the plugin loaded in each plugin program. 
◾ Improved track view display, with automation editing for plugin programs, and 

access to common track settings in the lane. 
◾ Improved the program editor for plugin programs. 
◾ You can drag samples to lanes in the grid to load them onto a pad. 
◾ Double-click in sequence editor to insert/remove a slice point. 
◾ Improved the hardware’s pad light performance. 
◾ Improved QLink performance. 
◾ Better preferences window, that looks better and is better organized. 
◾ Audio export of submixes and plugin programs. 
◾ Improved MPC 3000 file import. 
◾ Next sequence mode works like an MPC 4000, rather than an MPC 5000. 
◾ Many, many bug fixes. 
  

Version 1.2  (November 2012) 
  

Improvements 

◾ Many bug fixes and stability enhancements. 
◾ Improved the software installation procedure. 
  

Version 1.1  (October 2012) 
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New features 

◾ Support for MPC Studio hardware. 
◾ Support for ProTools. MPC runs as an RTAS format plugin inside ProTools 9 and 

ProTools 10. 
◾ Tracks are assignable to individual outputs in the Track Mixer. 
◾ Enhanced audio export, with better workflow and the ability to export individual 

Submix busses. 
◾ Support for Bank Select and Program Change MIDI messages. 
◾ Realtime sample playback indicator in the Sample Editor. 
◾ Selectable MIDI output port routing to DAW when running as a plugin. 
◾ Quick tool selection when grid editing using numeric keys. 
◾ Support for VST and Audio Unit plugin preset selection. 
  

Improvements 

◾ Improved audio synchronization when running as a plugin in Ableton Live, Logic, 
ProTools and Cubase. 

◾ Improved file save and load performance in plugin mode. 
◾ Improved performance when recording long sequences and automation. 
◾ Support for fullscreen mode and retina text display on Mac. 
◾ Improved support for 3rd party VST and Audio Unit plugins. 
◾ Bug fixes and stability enhancements. 
  

Version 1.0  (August 2012) 
  

This is the initial MPC software release, with support for MPC Renaissance hardware.
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